Blender Objekt hat nen komischen Schatten

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Blender Objekt hat nen komischen Schatten

      Hi, hab mit Blender nen Mesh erstellt und als FBX exportiert. Je nachdem wie nah ich in UE an das Objekt zoome bekomme ich einen kaputten Schatten. Im Spiel ist das leider identisch. In der Mitte wird Licht durchgelassen. Ich habe in Blender eine Hälfte erstellt diese gespiegelt und zusammengefügt.

      Dateien
      • boat8.fbx

        (25,71 kB, 34 mal heruntergeladen, zuletzt: )
      Meine UE4 Plugins gibt es hier.
    • DarkFaces schrieb:

      Das ist ein Querschnitt durch dein Boot.



      Der Vertex der mit 8 Edges verbunden ist dürfte dein Problem sein.
      Nö, die habe ich extra verbunden weil ich dachte das zwischen den zwei hälften eine Lücke wäre. Aber ob die Verbunden sind oder nicht macht keinen Unterschied.

      @Sleepy
      Verstehe ich leider nicht. ;(
      Hab das Ding 4 mal neu erstellt und war mit dem jetzigen zufrieden (das muss so verbogen sein). Ich gucke mal ob ich es bei einer Hälfte lasse und diese in UE einfach zusammen schiebe. Ansonsten gehts wieder von vorne los. *dead*

      EDIT:
      Mit zwei FBX mit je einer Hälfte passiert es nicht. Es liegt an der Verbindung in Blender denke ich. Bä....

      EDIT2:
      Passiert trotzdem. Man muss nur weiter raus zoomen. ;(
      Ich mach doch noch einen Versuch. Echt komisch. Ich habe meinen Player Character auch so gemacht und keine Probleme gehabt.
      Meine UE4 Plugins gibt es hier.

      Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von Socke ()

    • DarkFaces schrieb:

      Warum nicht einfach so?



      So hast du kein Non-manifold Mesh und es sollte funktionieren.
      Hö, sieht klasse aus. Da reichen meine Skills nicht aus für. Ich probiere hier aber seit Stunden rum und der Fehler scheint an Unreal zu liegen. Ich habe meine Sonne auf "Movable" gehabt. Weiß nicht warum. Ich hatte schomal Probleme damit und hab es normalerweise auf "Sationary". Damit sehen die Schatten normal aus. Auch mit dem komischen Boat.

      Ich bekomme jetzt ein Warning. Hab in der Doku auch eine Lösung. Ich finde die Einstellung aber nicht. Was ist der "generic browser"? Gibts die Einstellung noch?


      This warning is caused when there is a Static Mesh Actor in a level with a NULL StaticMesh property. This can be a problem because the Actor exists and is using memory, but does not have a Atatic Mesh to actually draw. This warning is usually the result of creating a StaticMesh Actor without first selecting a StaticMesh in the generic browser. This warning can be fixed by first selecting a Static Mesh in the generic browser and then going to the StaticMesh Actor's Property Window->StaticMeshActor Category->StaticMeshComponent->StaticMeshComponent Category to set the 'StaticMesh' Property

      EDIT:
      Wohl weitere UE Bugs. Nach Neustart des Editors kommt das Warning nicht mehr. Heute war nen schlechter Tag.

      Danke für eure Geduld.
      Meine UE4 Plugins gibt es hier.

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Socke ()

    • Kaid hat völlig recht du hast die falsche Einstellung und die falsche Herangehensweise !

      Ganz ehrlich und das ist echt nicht böse gemeint: Ich glaube nicht das es ein UE Bug ist da bin ich mit zu 99,999% sicher.

      Wenn ein Maurer ne Mauer krum und schief hochzieht kann er die Schuld auch nicht seinem Werkzeug geben :)

      Das wichtigste bei problemen ist es immer alle möglichen Ursachen zu eliminieren bis nur noch das Problem selber übrig bleibt.
      @DarkFaces sagte dir bereits das die wahrscheinliche Ursache an deinem Mesh liegt, das glaubst du nicht ? Dann erstell dir nen Cube zieh den so zurecht das er aussieht wie ein Boot und importiere den Cube mal mit einer sauberen Topologie und Fehler frei!

      Wenn es ein UE Bug wäre, dann wäre das Problem immer noch da und ich bin mir sicher das dies nicht so sein wird.

      Korrigiere dein Mesh, wenn du dann noch Fehlermeldungen, Schattenprobleme etc hast reden wir weiter.


      Wenn deine Skills nicht reichen, dann lerne es beschäftige dich damit.

      Gerade Anfänger drehen gerne an den UE4 Regeln bis das Problem dann vielleicht irgend wann verschwindet, aber ohne zu wissen warum das Problem nun verschwunden ist.
      Das ist schön für den Moment aber wenn das Problem irgend wann wieder auftritt stehen Sie wieder am Anfang.

      Also bitte versuche alle Fehlerquellen zu eliminieren und breche deine Szene so lange runter bis du das Problem gefunden hast.

      Nur so löst man Probleme.
    • Also ich würde noch einmal ganz locker von vorn starten.... Bei deinem Modell würde ich sagen.. das war zum lernen...
      Ich hatte am Anfang auch genau diese Probleme... und was soll ich sagen... gelernt wie es besser geht... und gemerkt es ist nicht die Engine...

      Es ist halt nicht das gefühlte... "ich zauber mal eben ein Modell, weil ich Blender starten kann und Flächen extrudiere...".
      Es gehört so viel dazu...

      Alleine fürs Shading.....
      Topology....
      Shading Groups
      Lightmap
      Map Baking
      usw....

      Aber das ist ja das Schöne... das man genau dieses alles anfängt zu verstehen und zu lernen...

      Mach Neu :)
      Genau so, nur anders....

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Aragom ()

    • Ich war mal so frei und hab dein Modell gesäubert. Dadurch sind leider die UV's nicht mehr existent da durch das Säubern alles kaputt gegangen ist. Da kannste mal ein bisschen Studieren:
      Dateien
      • Boot.fbx

        (20,72 kB, 36 mal heruntergeladen, zuletzt: )
      Showroom für alle! Zum Download Version 1.0
      Mein Youtube-Kanal: youtube.com/channel/UCE9epILPd2-CmneoMW_R4Pg
    • GameMaker schrieb:

      Aus was soll das Boot überhaupt bestehen? Aus Blättern? Holz? Dein Modell sieht ziemlich seltsam aus.
      Könnten auch zusammengeschweißte Metallplatten sein.
      Papier. Vorlage selber gebastelt.

      Nur mal so Leute. Zwei Cubes in Blender gedreht, zusammengeschoben, gejoint, exportiert -> gleicher Fehler. Da brauchen wir garnicht darüber zu diskutieren was ich falsch gemacht habe. Also was den Fehler betrifft. Das das Model Fehler hat ist mir klar. Aber solange man es nicht sieht und sonst keine Nachteile entstehen ist es mir schlicht egal bei diesem Model.

      @GameMaker Danke für die Mühe. Aber der Schatten ist in deiner Version genau so wie in meiner. Das ist zu 100% nen Fehler in der Engine, FBX Belnder Export oder FBX UE Import oder ich muss beim Import bestimmte Häkchen setzten.

      Probiert es einfach selber aus. Sonne muss auf "Movable" stehen. Ich benutze 4.16.1 aus Git.

      PS: Schaut mal in den UE Bugtracker. Mehr Bugs als im Regenwald. :P
      Meine UE4 Plugins gibt es hier.

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Socke ()

    • Was mir noch auffällt ist das die Board wand sehr dünn ist wodruch es vereinzelt zu Z-Fighting kommt. Auch ist das Mesh an einigen Stellen krum und schief wodurch das UV-Mapping schwieriger wird.

      Ich hab auch noch ein bisschen daran rumgebastelt, fehler ausgebessert und ne UV erstellt.



      boot_sleepy.fbx

      Sollte das Problem nun immer noch bestehen mach mal bitte ein Screenshot
    • Bei mir gibt es keine Probleme mit meiner ausgebesserten Version.
      Kein Z-Fighting, keine fehlerhaften Schatten - nichts. Sogar wenn ich weit rauszoome sieht das Boot und der Schatten normal aus.
      Bilder
      • Test.png

        1,21 MB, 1.225×740, 38 mal angesehen
      • Test2.png

        1,29 MB, 1.165×692, 36 mal angesehen
      Showroom für alle! Zum Download Version 1.0
      Mein Youtube-Kanal: youtube.com/channel/UCE9epILPd2-CmneoMW_R4Pg
    Unreal®, Unreal Engine, the circle-U logo and the Powered by Unreal Engine logo are trademarks or registered trademarks of Epic Games, Inc. in the United States and elsewhere.