Teleport funktioniert nicht

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Teleport funktioniert nicht

    Hey,
    Ich wollte gerade bei nem Blueprint ein Teleport einfügen. Leider passiert da nichts, obwohl ich ein True returned bekomme. Woran kann das liegen?
    Ich weiß leider nicht, welche Informationen ihr braucht, um mir sagen zu können, woran es liegen könnte, deswegen bitte ich euch darum, mir das zu schreiben, falls meine sehr knappe Beschreibung nicht reicht ^^

    MfG
    Timer
  • Mach mal ein Screenshot von deinem Blueprint.
    Sonst weiß ja keiner, was du falsch machst. :)

    Allein das hier in dein Character-Blueprint gesetzt (siehe Screenshot) sollte genügen, dass bei Taste B der Charackter zu 500,500,500 gesetzt wird.

    Die Option "Teleport" ist gesetzt damit die Physik des Characters keinen Einfluss nimmt, wenn der Character zur neuen Position gesetzt wird.
    Wenn du eine Velocity durch den Teleport auslösen möchtest, musst du das Häkchen weglassen. - z.B. bei Ragdoll-Geschichten usw.
    Und mit "Sweep" würdest du zusätzlich mit Objekten kollidieren, die zwischen alter und neuer Position stehen - falls du das benötigst.
    In dem Fall wird an der Kollisionsstelle der Teleport beendet.
    Bilder
    • chartp.jpg

      18,8 kB, 525×259, 46 mal angesehen
    F99

    Dieser Beitrag wurde bereits 11 mal editiert, zuletzt von Franz99 ()

Unreal®, Unreal Engine, the circle-U logo and the Powered by Unreal Engine logo are trademarks or registered trademarks of Epic Games, Inc. in the United States and elsewhere.